GME worthy to repair?

#1
the Mic is MC534B with menu button. I just bought this car equipped with this, I found this unit has these issue. Console hide under the dash, power and antenna cable linked well. The Mic turn on, the console green light lit. Choose a channel, it can transmit, but no receiving at all. Silent when surfing channels. Tried to press MENU buttons to try to find some issue, failed.

What does it cause? Is there a good guy to fix it? or I can do myself to reset it? I live Brisbane South side, Archerfield. Thanks for your advice.
 

Triton14

Well-Known Member
#2
My suggestion is write an email to GME tech support, they might have an easy answer for you?
They were very good to me with issues I had with a 2nd hand CB I got from a friend & they even gave me a free 40ch to 80ch software upgrade!
 
Last edited:

Traveller

4x4 Earth Contributer
#4
I'd read the manual -or download one to read if it didn't come with one - it could be a squelch issue, maybe cctss settings- does the display show any bars, any static noise at all? What model gme?
 
#6
thanks for your response. The issue is settings I cant get in, the menu button pressed, no any information come up. I turn the antenna, lift the antenna, found a loose wire insert into the long tube. Other end connected to console is fine. I dont want to spend too much to fix this, as even a new unit cost not much.
 
#7
thanks for your response. The issue is settings I cant get in, the menu button pressed, no any information come up. I turn the antenna, lift the antenna, found a loose wire insert into the long tube. Other end connected to console is fine. I dont want to spend too much to fix this, as even a new unit cost not much.
It's locked then. Will only allow you to do some buttons just download a manual it should tell you how to unlock it...
 
#8
thanks. I will try to find the model and download its manual. Not promising, as no buttons on the console. No lock button on the micphone. Maybe need to reset or programming, as it came from mining site. Must somebody looked after this.
 
#9
thanks. I will try to find the model and download its manual. Not promising, as no buttons on the console. No lock button on the micphone. Maybe need to reset or programming, as it came from mining site. Must somebody looked after this.
Something like this happened to mine, maybe on the menu key...
I think being a mining vehicle they've made it idiot proof probably using ctcss code as well or sellcall.


The TX3400 has a number of features that can be disabled individually by the user to allow for much simpler operation. These include the Priority, Scan, Duplex and Squelch/CTCSS functions that are normally accessed via keys on the front of the radio.

To disable one of the keys:
1. Turn the radio OFF using the volume control.
2. Press and hold the key you wish to disable while turning the radio back on.
A low beep will be heard and the selected key will no longer function.
 
#10
thank you, Swaggie。 Have contact a dealer to check, the selle took the external speaker. No audio output. Bought a GME external speaker, sadly, no volumn control on speaker and Mic this function does not work neither. But at least it is working now. The GME tech email me MC 534B should not used on 3600 series, the volumn control wont work .

Will buy another speaker with volumn control instead, also with bluetooth, can be for leisure as well.

Thank you guys.
 

Petunia

Well-Known Member
#11
I turn the antenna, lift the antenna, found a loose wire insert into the long tube.
I would hazard a guess? things tend to go fritz bang when shoved together? [ i say it again, o2 thief used hotmelt glue of all the dumbass ideas he could have opted for] I would not be transmitting on the antennae until it was properly connected > soldered < or however a good contact is made in the base of that particular antennae?:cool:
 

Traveller

4x4 Earth Contributer
#13
2nd pic looks like a nitto air fitting, possibly for a sand/mining flag. What is connected to the antenna in pic 1-the one still attached? Possibly able to use a similar aerial on the second base, some need soldering, some just screw in.
 
#14
2nd pic looks like a nitto air fitting, possibly for a sand/mining flag. What is connected to the antenna in pic 1-the one still attached? Possibly able to use a similar aerial on the second base, some need soldering, some just screw in.
Yes, a 1m long antenna was inserted and screw in. I tried to find soldering point or screw, did not find. Is that meant to be?
 

Traveller

4x4 Earth Contributer
#15
You need to look up gme, motorola, uniden etc and look at aerials to see if one matches what you have. Easy enough to remove the old base and wire in a new one-there are instructions on how to reconnect uhf cable-trimmimg, soldering etc.
 
#16
that's a RFI antenna. it's broken. can't be fixed as that bare wire is the tuning stub. Little bit hard to see if it can be unscrewed from the pic. but if it can, then you can just buy a replacement antenna. We have them in stock if you are in Adelaide. Otherwise give RFI a call to see who is your closet agent. GME is worth fixing. We are a GME warranty repairer in SA and we can generally fix anything and everything under $150. Replacement mic is around $165. But you won't regret buying a new XRS370. They are absolutely amazing in EVERY aspect.
 

Petunia

Well-Known Member
#17
My honest and most UNprofessional opinion, get the sidecutters out and delete the whole lot! Start fresh with good gear, that will work out of a sealed box.:cool:
 
Top