60 series brakes

jack doff

New Member
60 series brakes dramas

60 series with a 12ht
occasionally when idling around, i'm on and off the brakes and my pedal goes rock hard and the brake light comes on.
i got a hint that my vacuum lines had started to perish. i replaced them all and had no probs for a couple of weeks.
yesterday it happened again. its really pissing me off.
has anyone had this prob?
any ideas on what to check/fix?
any input grateful.
 
Last edited:

Lockeyhj61

New Member
Hi dont no if this wiil help had the same problem on my hj61 got told if the front dics get thin can worp them so I had slotted dics put in 8 mouth ago and no problems and it stops a lot better cost for slotted dics were $120 a pair I am not a expert but it fixed my problem:D
 

tipperw

New Member
61 Brakes

Hi Jack,
Have a 61 with the same problem. Have a new alt/pump fitted, slow developed vacume loss, Best mod I found was connecting a boost/vac guage to the vac lines near the firewall as I now have a vac guage to see what vac I have while driving. can see when I will runout of brakes and any sealing work on hoses etc. can be checked. slowly as leaks in the system were repaired things like ac idle up and cold motor, steering started to work. Not perfect yet but inproving.

Good Luck, takes time but very rewarding.

Go the 60,s
Rick
 

Rumbuck

Member
Yeah, I had a vac leak, changed lines, no issues.

That said, I plan to go electric vac pump so I can fit a 160A alternator.
 

Roderick Long

New Member
Yeah, I had a vac leak, changed lines, no issues.

That said, I plan to go electric vac pump so I can fit a 160A alternator.
Hi how are you going, Just wondering if you did change your alternator and fit an electric vacuum pump.
This is something that i was looking into ages ago but could not get an answer from anyone.
I would be very interested to find out how you did the conversion.
Thanks..
 
Top