3.0 zd30 limp mode on hot windy day

#1
Hi. I am new to here.
I have an 04 nissan patrol with a 3.0 litre zd30. On hot windy days only it goes into limp mode. On a hot day it is fine on a windy day it is fine but both together it happens. Does anyone have any ideas what the issue might be.
Thanks in advance
 

mikehzz

Well-Known Member
#2
I had a limp mode condition that was intermittent and seemed to be temperature related. It turned out to be an intercooler hose that was too soft and ballooning out. Have you put an ODBII reader on the car?
 

patrolgu4

Active Member
#4
I tried pluging in a reader but it wont register the car for some reason
G'day,
04 Patrol is not OBD2 capable/compliant you need to use Consult 2 compliant hardware/software. That's even though the diagnostic plug looks like OBD2, that's just dodgy Nissan for you. Then again limps related to overboost/overfuelling/increased air flow are not registered either

The causes for limp are various but it is mostly down to MAF sensor (Manifold airflow sensor) readings exceeding the safe settings at given RPM and TPS (accelerator pedal) position. So what it can mean on the hot day make air to thin and windy conditions make the engine work extra hard so combined that will cause turbo charger to generate extra air flow under certain throttle position and you'll get the dreaded limp. If your car is unmolested (not modified with extra boost controls etc.) then I'd consider changing MAF if it is indeed that. You can also have an issue with turbo charger over boosting so anything over 18 psi will increase air flow which will cause limps under certain conditions aka MAF vs RPM vs TPS = > then safety map results in limps.
If you got leaking intercooler or dodgy hoses that will also be exposed under extreme conditions. ZD30 turbo control always play catch-up so any problem will be exposed as limps.....

I'm not aware that ZD30 has engine overheat protection which would kick in and

Mind you if yours is stock with no mods I suggest you to have at least boost and EGT gauges fitted so you can keep an eye on the proceedings better.

Regards
 
#5
Thank you. I did discover a small split in the acctuator hose which i have replaced today but now need the right conditions to see if it helps but i will look in to maf sensor and tps
 

billolga

4x4 Earth Contributer
#6
I tried plugging in a reader but it wont register the car for some reason
Turn the key on & run a wire from Pin 1 to Pin 8 (Bottom outside pins) for a few seconds & then remove it.
The Check Engine Light will flash slow for the first number & fast for the next. (And then the next fault if it has one)
(55 = No ECU fault)
If you put the wire back while the Ignition is still on it will clear the codes.
When I had my ZD30 Engine, I bought an OBD2 plug from Jaycar & wired the two pins to a press button - cheap & easy.
Gregory's Patrol Manual No 519 tells you how to do this plus a list of the Fault Codes.
-------
I actually added a change over switch & wires to read Prado's as well. :cool::)
 

2002GU3

Well-Known Member
#7
G'day mate, welcome to earth.........if your still having issues after changing the actuator hose, go to "patrol 4x4" forum and look up limp mode or NADS there are hundreds of posts regarding limp issues and how to solve them, I used to get limp until I put a dawes needle and valve on, haven't had limp mode since...
 
Top